Linux Setup

From Violated Heroine
Jump to: navigation, search

Requirements[edit]

  • The knowledge and ability to edit files and run commands as root
  • EasyRPG Player
  • unrar
  • rsync
  • The Japanese RPG Maker 2000 RTP, which can be downloaded here or here (executable archive, set $LANG before extracting, see below to extract the installer correctly)

Generating the Japanese Locale[edit]

The location of the locale configuration file and method for generating the locale can vary from distro to distro, so instructions are split in to sections by distro.

Ubuntu[edit]

This should work for all apt-based distros. Run as root :

locale-gen ja_JP.UTF-8

ArchLinux[edit]

Uncomment ja_JP.UTF-8 UTF-8 in /etc/locale.gen, then run as root :

locale-gen

Void Linux[edit]

Uncomment ja_JP.UTF-8 UTF-8 in /etc/default/libc-locales, then run as root :

xbps-reconfigure -f glibc-locales

Using EasyRPG Player[edit]

EasyRPG Player works flawlessly.

Download the RTP files from here then extract the RTP files with

1=LANG=ja_JP.UTF-8 unrar x -ad RTP2000JP.rar

Then extract VH with :

1=LANG=ja_JP.UTF-8 unrar x -ad VH_*.rar 

and merge the RTP files into VH with :

rsync --verbose --archive --ignore-existing RTP2000JP/RTP\($'\346'$'\227'$'\245'$'\346'$'\226'$'\207'\)/ VH_1601025_translated_V1/

(make sure to keep the slashes on the ends of the paths.) Then add :

1=FullPackageFlag=1 

to your RPG_RT.ini above GameTitle then cd into the directory and run :

easyrpg-player

Notes:

  • EasyRPG Player won't run if something else has exclusive control of the (ALSA) audio device (e.g. pulseaudio)